mc_rack crashes during replay w/ filter

View previous topic View next topic Go down

mc_rack crashes during replay w/ filter

Post  Salain on Mon Aug 25, 2008 5:13 am

the data replayer in mc_rack crashes most (but not all of the time) when I replay a file with the filter on. The program crashes with a send error report message for mc_rack.exe, the offset is listed at the bottom of this message. I have tried version 3.5.10 and 3.5.8 on two different computers. The first is a Pentium IV w/ hyperthreading, 500Mb ram, running win xp pro, it is the computer the recordings were made from. I have tested the computer with hyperthreading off and on, HT was off for the recording. The second computer is running win xp home, core 2 duo, 1Gb ram. The results are identical between computers, replay works fine until a filter is added. Even if the filtered data is not being displayed, the program will crash.

If I step through the data with the replayer, I can sometimes get results for 3 or 4 2second steps. Other times, the program will crash on the first attempt. If I *do* have some succesful filterings, the crash will sometimes happen when I am performing random functions such as clicking the high/low pass radio buttons. Results are the same for any files I have tried it on. I can do the analyses in matlab with some work, but it would be nice if this worked.

Thanks,
Cameron

AppName: mc_rack.exe Offset: 00040705

Salain

Posts : 2
Join date : 2008-08-25

View user profile

Back to top Go down

Re: mc_rack crashes during replay w/ filter

Post  Frank MCS on Mon Aug 25, 2008 7:24 pm

Dear Cameron,
I tried to reproduce the problem here, but I could not get the program (3.5.10) to crash. Could you tell us what kind of data and what kind of filter settings you are using? I used a file with continuous data/all channels/20kHz for my test, and a 20Hz high pass filter.

Regards Frank MCS
avatar
Frank MCS

Posts : 184
Join date : 2008-07-14

View user profile

Back to top Go down

Re: mc_rack crashes during replay w/ filter

Post  Salain on Tue Aug 26, 2008 5:25 am

Data is 2 seconds of silence, 2 seconds of recording, 18 seconds of silence, repeat. Filtering above and below 200 Hz, makes no difference if it's high or low pass. All channels are displaying, recordings are at 20khz.

Crashes occur at 2 primary times: after I hit play and filtering is occurring, and after a successful filter when I click the high/low pass radio button. The crashes are frequent, but sporadic.

If you still can't reproduce it I can send you a file.

Salain

Posts : 2
Join date : 2008-08-25

View user profile

Back to top Go down

Re: mc_rack crashes during replay w/ filter

Post  Frank MCS on Tue Aug 26, 2008 7:21 pm

Dear Cameron,
sorry, I don't quite understand what you mean by 2s silence-2s rec-18s silence. Is this triggered data? Maybe it is best if you could give me a download link for a datafile and also the rack that you are using. My e-mail is hofmann@multichannelsystems.com.

Regards Frank
avatar
Frank MCS

Posts : 184
Join date : 2008-07-14

View user profile

Back to top Go down

Re: mc_rack crashes during replay w/ filter

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum